Pixelitor Installation

Starting with the version 3.0.0, Pixelitor requires Java 8. (Pixelitor 2.3.0 was the last version that ran on Java 7 and Pixelitor 1.1.2 was the last version for Java 6 - if for some reason you can have only old Java versions, check out these versions) The download does not contain the Java Runtime Environment.